Visual Studio Professional 2015-Test-Abdeckung

Ich versuche zu konfigurieren opencover mit Visual Studio 2015 Professional edition.

Verwende ich Visual Studio, MS Build-Test-tool für Unit-Tests.

Habe ich ein paar Herausforderungen auf diesem

1.Zuerst habe ich installiert opencover Version 4.6.519

  1. Dann report-generator Version 2.4.3.0

Erste Herausforderung, die ich konfrontiert bin ist immer das Test-Ergebnis aus put, die von visual studio. Bei mir läuft auf Standard-Konfiguration testen.

Obwohl es erstellt Test-Ergebnis-Ordner , sehe ich keine test-Ergebnis-Datei zur Verfügung.

Dann habe ich versucht zu installieren OpenCover UI-Erweiterung verfügbar hier.

Einmal habe ich installiert, ich bekomme folgenden Fehler ,

Visual Studio Professional 2015-Test-Abdeckung

Eine Ausnahme aufgetreten ist , Konnte Nicht gut ein Teil des Pfades
C:\Benutzer\MyUserAccount\Desktop\MyApp\123244-43434-343434….\TestResults

Entnehmen Sie bitte herauskommen, Fenster Für Weitere Details.

Wenn ich das Ergebnis-Fenster dies ist der out-put

Fehler: Keine der test-Container passen die Plattform-Architektur und .Net Framework-Einstellungen für den Testlauf. Plattform: X86 .Net Framework: Framework45. Gehen Sie zu http://go.microsoft.com/fwlink/?LinkID=330428 weitere Informationen zum verwalten dieser Einstellungen.

Nicht finden konnte, ein Teil des Weges
‚C:\Users\vsuvinith\Desktop\RFS\OpenCover\f83ba963-16d1-450d-915b-6920d402c961\TestResults‘.
System.IO.__Fehler.WinIOError(Int32 errorCode, String maybeFullPath)
System.IO.FileSystemEnumerableIterator1.CommonInit() at
System.IO.FileSystemEnumerableIterator
1..ctor(String path, String
originalUserPath, String searchPattern, SearchOption searchOption,
SearchResultHandler`1 resultHandler, Boolean checkHost) bei
System.IO.- Verzeichnis.GetFiles(String path, String searchPattern) bei
OpenCover.UI.Prozessoren.MSTestExecutor.UpdateTestResultsFile() bei
OpenCover.UI.Prozessoren.MSTestExecutor.ReadTestResults() bei
OpenCover.UI.Prozessoren.TestExecutor.Execute() bei
OpenCover.UI.Befehle.ExecuteSelectedTestsCommand.b__1()

Andere Dinge, die helfen könnten.

  • Bauen ist in X64
  • Läuft auf Windows 7 Enterprise Edition.
  • Läuft auf Standard-Konfiguration keine Konfiguration getan hat.

kann mir jemand helfen, auf immer dies gelöst.

InformationsquelleAutor Viduru | 2016-02-14

 

One Reply
  1. 0

    Viduru.
    Sind Sie sicher, dass Sie ausführbare Dateien, richtig?
    Am Anfang OpenCover wird Sie bitten, zu finden ausführbaren Dateien.
    Dies ist ein OpenCover.Console.exe – Datei.
    Sie können es in %localappdata%\Apps\OpenCover nach der Installation .msi-Datei von https://github.com/opencover/opencover/releases (opencover.4.6.519.msi)

    • Ich habe genau den selben Fehler. Ich habe die gleiche version installiert von der msi, die Sie erwähnen. Dort nicht scheinen sein irgendwelche anderen Konfigurationseinstellungen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.