Upgrade Reagieren, gebürtig von 0.57 auf 0.58.5

Nach dem Upgrade auf React Native 0.58.5 von 0.57, gibt es eine Fehlermeldung, wenn die Installation einer npm Modul:

npm WARN react-[email protected].58.5 requires a peer of [email protected].6.3 but none is installed. You must install peer dependencies yourself.
npm ERR! path C:\d\code\js\emps\node_modules\colors
npm ERR! code ENOENT
npm ERR! errno -4058
npm ERR! syscall rename
npm ERR! enoent ENOENT: no such file or directory, rename 'C:\d\code\js\emps\node_modules\colors' -> 'C:\d\code\js\emps\node_modules\.colors.DELETE'
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\JunC\AppData\Roaming\npm-cache\_logs\2019-02-25T23_49_59_940Z-debug.log

Ist hier der Teil, der package.json:

"dependencies": {
    "react": "^16.8.2",
    "react-native": "^0.58.5",
    "react-native-code-push": "^5.5.2",
    "react-native-device-info": "^0.26.4",
    "react-native-gifted-chat": "^0.7.2",
    "react-navigation": "^3.3.0"
  },

Den react version ist alreay 16.8.2 was neuer ist als das, was die Meldung vorschlägt. Was verursacht die Fehlermeldung? Ist die react-native zu neu?

  • Haben Sie versucht npm ci zu beginnen mit einer sauberen installation?
  • Wahrscheinlich nicht. Ich kann mich nicht erinnern, Tat ich das. Das Projekt wurde mit react native 0.57 ein paar Wochen vor und ich habe ein upgrade auf 0.58.5 und das ist, wenn ich sehen, beginnen die Fehler. Gibt es eine Möglichkeit, den Fehler zu beheben?
  • Ich meine, dass Sie versuchen könnte, schreiben npm ci jetzt zu entfernen Sie alle node_modules und starten mit einer frischen Installation.
  • hast du direkt die geänderte version im Paket.json und dann habe npm installieren ?
  • Was ich Tat, war die Neuinstallation des gesamten Systems und beachten Sie, dass die reagieren, version gesperrt-16.6.2 die ist nicht die neueste (16.8.2). Kann das problem der Inkompatibilität Probleme, die durch neuere react.
InformationsquelleAutor user938363 | 2019-02-26



2 Replies
  1. 1

    Bezug auf die npm ERR! Sie sind zum ausführen erforderlich npm install color -S als color Paket fehlt aus Ihrer json-Datei.

    hoffe, das hilft!

  2. 0

    Habe ich am Ende Neuinstallation des gesamten Systems und beachten Sie, dass die reagieren, version gesperrt-16.6.2 die ist nicht die neueste (16.8.2). Kann das problem der Inkompatibilität Probleme, die durch neuere reagieren. Hier ist Teil package.json nach der neu-installation:

     "dependencies": {
        "react": "16.6.3",
        "react-native": "0.58.5",
        "react-native-code-push": "^5.5.2",
        "react-native-device-info": "^0.26.4",
        "react-native-gifted-chat": "^0.7.2",
        "react-native-navigation": "^2.12.0",
        "react-navigation": "^3.3.2"
      },
      "devDependencies": {
        "babel-core": "7.0.0-bridge.0",
        "babel-jest": "24.1.0",
        "jest": "24.1.0",
        "metro-react-native-babel-preset": "0.52.0",
        "react-test-renderer": "16.6.3"
      },
      "jest": {
        "preset": "react-native"
      }
    • Das scheint Recht gegeben, die auf den CHANGELOG die Letzte Erwähnung eines react version bump war in 0.57.8 auch Blick auf die git diff zwischen 0.57 und 0.58.5 es war eine Beule von 16.5.0 zu 16.6.3

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.