Plattform nicht unterstützt wird, wenn ausgeführt `npm laufen, fließen`

Ich bin auf Ubuntu 14.04. Knoten version ist 4.5.0. npm version ist 2.15.9.

Habe ich flow-bin version 0.32.0 in meinem package.json Entwicklung von Abhängigkeiten:

$ cat package.json | grep flow-bin
"flow-bin": "^0.32.0",

Den flow-bin Paket lokal verfügbar ist:

$ npm ls --depth 0 | grep flow
serverside-node-babel-mocha-[email protected].0.0 /home/mperdikeas/test-project
├── babel-plugin-transform-flow-strip-[email protected].14.0
├── flow-[email protected].32.0

Meine npm run flow Ziel ist:

cat package.json |  grep \"flow\"
"flow": "flow; test $? -eq 0 -o $? -eq 2",

Wenn ich npm run flow bekomme ich die folgende trace:

$ npm run flow

> serverside-node-babel-mocha-[email protected].0.0 flow /home/mperdikeas/test-project
> flow; test $? -eq 0 -o $? -eq 2

/home/mperdikeas/test-project/node_modules/flow-bin/cli.js:20
  throw new Error('Platform not supported.');
    ^

Error: Platform not supported.
    at Object.<anonymous> (/home/mperdikeas/test-project/node_modules/flow-bin/cli.js:20:9)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Function.Module.runMain (module.js:441:10)
    at startup (node.js:139:18)
    at node.js:974:3

npm ERR! Linux 3.13.0-62-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "flow"
npm ERR! node v4.5.0
npm ERR! npm  v2.15.9
npm ERR! code ELIFECYCLE
npm ERR! serverside-node-babel-mocha-[email protected].0.0 flow: `flow; test $? -eq 0 -o $? -eq 2`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the serverside-node-babel-mocha-[email protected].0.0 flow script 'flow; test $? -eq 0 -o $? -eq 2'.
npm ERR! This is most likely a problem with the serverside-node-babel-mocha-flow package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     flow; test $? -eq 0 -o $? -eq 2
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs serverside-node-babel-mocha-flow
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR!     npm owner ls serverside-node-babel-mocha-flow
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /home/mperdikeas/test-project/npm-debug.log

Wenn ich direkt flow aus der Schale (ohne npm und package.json) bekomme ich eine identische Spur:

$ ./node_modules/flow-bin/vendor/flow
/home/mperdikeas/test-project/node_modules/flow-bin/cli.js:20
  throw new Error('Platform not supported.');
    ^

Error: Platform not supported.
at Object.<anonymous> (/home/mperdikeas/test-project/node_modules/flow-bin/cli.js:20:9)
at Module._compile (module.js:409:26)
at Object.Module._extensions..js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at Object.<anonymous> (/home/mperdikeas/test-project/node_modules/flow-bin/vendor/flow:16:1)
at Module._compile (module.js:409:26)
at Object.Module._extensions..js (module.js:416:10)

Was ist der Sinn dieser Botschaft, d.h. die Plattform wird nicht unterstützt? und wie kann ich das beheben?

Meine anderen Ziele (z.B. npm run test und npm run start) funktionieren. Es scheint, dass dies im Strömungsverhalten.



One Reply
  1. 3

    Flow erfordert ein 64-bit Betriebssystem. Ist es möglich, Sie eine 32-bit version von Ubuntu?

    https://github.com/facebook/flow/issues/270 hat den Zusammenhang, warum Fließen derzeit sind 64 bit.

    • Ja, das war ein 32-bit-Ubuntu 14.04-system. Das gleiche setup arbeitete in einer 64-bit-Ubuntu 14.04-system ohne Probleme.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.