Nicht verlangen kann laravel/Reisepass mit dem Komponisten

Wenn ich composer require laravel/passport bekomme ich

Version ^5.0 für laravel/Pass ./Komponist.json wurde
aktualisierte Be-composer-Repositorys mit package Informationen
Aktualisieren Sie die Abhängigkeiten (einschließlich require-dev) Ihren Anforderungen könnte
nicht aufgelöst werden, um eine installierbare Gruppe von Paketen.

Problem 1
– Installation-Anforderung für laravel/Pass ^5.0 -> satisfiable von laravel/Pass[v5.0.0].
– Fazit: entfernen laravel/framework v5.5.34
– Fazit: nicht installieren laravel/framework v5.5.34
– laravel/Reisepass v5.0.0 erfordert beleuchten/Verschlüsselung ~5.6 -> satisfiable von illuminate/Verschlüsselung[v5.6.0, v5.6.1, v5.6.2, v5.6.3].
– nicht installieren beleuchten/Verschlüsselung v5.6.0|nicht installieren laravel/framework v5.5.34
– nicht installieren beleuchten/Verschlüsselung v5.6.1|nicht installieren laravel/framework v5.5.34
– nicht installieren beleuchten/Verschlüsselung v5.6.2|nicht installieren laravel/framework v5.5.34
– nicht installieren beleuchten/Verschlüsselung v5.6.3|nicht installieren laravel/framework v5.5.34
– Installation-Anforderung für laravel/framework (gesperrt bei v5.5.34, erforderlich 5.5.*) -> satisfiable von laravel/framework[v5.5.34].

Installation ein Fehler aufgetreten ist, wiederherstellen ./Komponist.json zu seiner ursprünglichen
content.

Ich denke, das bedeutet, dass meine version von illuminate/encryption ist nicht kompatibel mit dieser version von laravel/passport

Ist das richtig? Was ist der beste Weg, um dieses Problem beheben? Ich kann nicht einmal herausfinden, wie um zu sehen, welche version von illuminate/encryption ich habe. Es nicht zeigen, bis in composer show.

Hier ist mein Komponist.json

{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=7.0.0",
        "fideloper/proxy": "~3.3",
        "laravel/framework": "5.5.*",
        "laravel/tinker": "~1.0",
        "tymon/jwt-auth": "dev-develop"
    },
    "require-dev": {
        "filp/whoops": "~2.0",
        "fzaninotto/faker": "~1.4",
        "mockery/mockery": "~1.0",
        "phpunit/phpunit": "~6.0",
        "symfony/thanks": "^1.0"
    },
    "autoload": {
        "classmap": [
            "database/seeds",
            "database/factories"
        ],
        "psr-4": {
            "App\\": "app/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests/"
        }
    },
    "extra": {
        "laravel": {
            "dont-discover": [
            ]
        }
    },
    "scripts": {
        "post-root-package-install": [
            "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
        ],
        "post-create-project-cmd": [
            "@php artisan key:generate"
        ],
        "post-autoload-dump": [
            "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
            "@php artisan package:discover"
        ]
    },
    "config": {
        "preferred-install": "dist",
        "sort-packages": true,
        "optimize-autoloader": true
    }
}
InformationsquelleAutor Matt D | 2018-02-18



2 Replies
  1. 9

    Passport 5.0, hängt von der version 5.6 der Illuminate Pakete. Ich kann sehen, Sie haben Laravel 5.5 installiert, also entweder upgrade von Laravel auf 5,6 oder verwenden Sie den 4.0-Zweig der Reisepass.

    Den "require" Abschnitt composer.json im Pass-repository hat Sie alle angegeben:

    "require": {
        "php": ">=7.0",
        "firebase/php-jwt": "~3.0|~4.0|~5.0",
        "guzzlehttp/guzzle": "~6.0",
        "illuminate/auth": "~5.6",
        "illuminate/console": "~5.6",
        "illuminate/container": "~5.6",
        "illuminate/contracts": "~5.6",
        "illuminate/database": "~5.6",
        "illuminate/encryption": "~5.6",
        "illuminate/http": "~5.6",
        "illuminate/support": "~5.6",
        "league/oauth2-server": "^6.0",
        "phpseclib/phpseclib": "^2.0",
        "symfony/psr-http-message-bridge": "~1.0",
        "zendframework/zend-diactoros": "~1.0"
    },

    Den Illuminate Versionsnummern line-up mit den Rahmenbedingungen, also Laravel 5.6 verwenden würde, Beleuchten 5.6, 5.5 verwenden würde, Beleuchten 5.5, etc.

    Finden Sie unter: Upgrade-Anleitung – Upgrade Auf 5.6.0 Von 5,5.

    • Ist dies so einfach wie das ändern der Komponist.json zu Laravel 5.6 und tun composer update? Oder gibt es weitere beteiligte?
    • Es ist mehr als die beteiligten, obwohl das upgrade auf 5.6 wurde die einfachste noch, imo. Hier die komplette upgrade-Handbuch.
  2. 0

    Ich hatte das gleiche Problem bin ich mit dem Laravel-Framework 5.4

    Hab es gelöst, indem Sie eine niedrigere version von passport

    composer require laravel/passport "4.0.3"

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.