Nicht in der Lage zu aktualisieren, nodejs und npm auf Raspbian-Raspberry Pi-3

Mein raspbian-system gerade läuft Node.js v4.8.2 und ich versuche, installieren Sie die neueste version, aber vergeblich.Ich habe versucht die folgende Lösung aus diesem post npm-Befehl funktioniert nicht unter ubuntu (ich.e deinstallation der alten Pakete und die Installation von neuen).Wenn Sie diesen Befehl verwenden sudo apt-get install -y nodejs bekomme ich diese Meldung:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libiw-dev : Depends: libiw30 (= 30~pre9-8) but 30~pre9-12 is to be installed
 nodejs : Conflicts: nodejs-legacy
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Ich habe auch versucht, die Installation von NPM direkt mit diesem Befehl: sudo apt-get install npm, aber ich bekomme diese Meldung:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libiw-dev : Depends: libiw30 (= 30~pre9-8) but 30~pre9-12 is to be installed
 npm : Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 3.0.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-underscore but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Jede Hilfe würde geschätzt werden.Dank

  • nachdem Sie versucht apt --fix-broken install?
  • Ja, aber es funktioniert nicht.Wenn ich mit Knoten -v es noch zeigen v4.8.2 .
InformationsquelleAutor Elfin forest | 2018-01-20



One Reply
  1. 4

    Das problem kommt von dieser Zeile:

    nodejs : Conflicts: nodejs-legacy

    Sollten Sie entfernen Sie alle Versionen der Knoten zuerst.

    (Folgende Befehle kann verwiesen werden auf raspberrypi.org’s community-Seite):

    [email protected]:~ $  sudo su -
    [email protected]:~ # apt-get remove nodered -y
    [email protected]:~ # apt-get remove nodejs nodejs-legacy -y
    [email protected]:~ # apt-get remove npm  -y # if you installed npm

    Stellen Sie sicher, Sie wies auf die korrekte Quelle.

    [email protected]:~ # curl -sL https://deb.nodesource.com/setup_5.x | sudo bash -

    Installieren und prüfen Versionen:

    [email protected]:~ # apt-get install nodejs -y
    [email protected]:~ # node -v
    [email protected]:~ # npm -v
    • Ja das problem war mit den Konflikten. Dieser arbeitete.
    • froh, zu Diensten zu sein 🙂

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.