ngx-Berechtigungen Fehler mit der Richtlinie *ngxPermissionsOnly

Ich habe ein problem mit der Richtlinie der Bibliothek ngx-Berechtigungen.
Diese sind die Versionen von my Winkel-die Abhängigkeit:

    "@angular/animations": "^5.0.3",
    "@angular/common": "^5.0.3",
    "@angular/compiler": "^5.0.3",
    "@angular/core": "^5.0.3",
    "@angular/forms": "^5.0.3",
    "@angular/http": "^5.0.3",
    "@angular/platform-browser": "^5.0.3",
    "@angular/platform-browser-dynamic": "^5.0.3",
    "@angular/router": "^5.0.3",

Und ich bin nach dieses Beispiel.

Ich bin mit der version des Moduls:

import { BrowserModule } from '@angular/platform-browser';
import { NgModule } from '@angular/core';

import { AppComponent } from './app.component';

import { NgxPermissionsModule } from 'ngx-permissions';

@NgModule({
  declarations: [
    AppComponent
  ],
  imports: [
    BrowserModule,

    //Specify your library as an import
     NgxPermissionsModule.forRoot()
  ],
  providers: [],
  bootstrap: [AppComponent]
})
export class AppModule { }

Ich die Dienste nutzen kann, ohne problem, aber ich habe einen Fehler nur mit der Richtlinie.
Der Fehler ist der nächste:

Can't bind to 'ngxPermissionsOnly' since it isn't a known property of 'div'. ("
    </div>
            </div>
                <div [ERROR ->]*ngxPermissionsOnly="['ADMIN', 'GUEST']" class="m-portlet__head-tools">
                    <ul class="nav nav-pil"): ng:///DashboardModule/[email protected]:10
Property binding ngxPermissionsOnly not used by any directive on an embedded template. Make sure that the property name is spelled correctly and all directives are listed in the "@NgModule.declarations". ("
                    </div>
                </div>
                [ERROR ->]<div *ngxPermissionsOnly="['ADMIN', 'GUEST']" class="m-portlet__head-tools">
                    <ul class="nav na"): ng:///DashboardModule/[email protected]:5



2 Replies
  1. 0

    Möchte ich sagen, dass ich auch vor demselben Problem. aber in meinem Fall; ich hatte ein shared-Modul, und ich Tat dasselbe wie wiki sagt aber Lösungen war nur die Ausfuhren NgxPermissionsModule.

    Mein Problem ging und der code ist in Ordnung.Überprüfen Sie, ob Sie haben den gleichen Fall und mein fix funktioniert für Sie.

    Dank

  2. 0

    Dieses problem tritt vor allem, dass die Abhängigkeit der Bibliothek. In Ihrem Paket.json hinzufügen dieser Abhängigkeit „ngx-Berechtigungen“. Wenn diese Abhängigkeit bereits vorhanden, dann nur ein upgrade-Bibliothek mit neueren version. Tun npm installieren von terminal-Fenster.

    Ich denke, dass problem wird sich lösen, sobald Sie dieses Verfahren befolgen.

    Danke.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.