NetBeans nicht finden können, JDK 10 habe ich installiert

Lese ich die Java ee erste Tasse, und ich muss JDK8+, meine version ist älter, so ich mein java aktualisiert, Konfigurieren Sie das System-Pfad zu Installieren, damit ich erfolgreich ausführen java -version in der Eingabeaufforderung, und es erkennt mich, ich habe es erfolgreich installiert, aber wenn ich mein NetBeans, kann Es nicht finden Java! Nicht nur das, sondern auch mein Eclipse neon nicht finden können java! Ich check das eclipse.ini, vielleicht es brauchen nur ein JDK 8. Also ich Frage mich nur, wie kann ich NetBeans fand meine Java?

  • Oh,Mein jDK-version log:java version „10“ 2018-03-20
  • ich hatte simular mit netbeans 8.2 installieren netbeans dev edition
  • Ich versuche, es zu beheben,Aber,JDK 10 wurde nicht unterstützt von NetBeans.Also einfach entwürdigend das JDK 1.8 144+.
  • ja, aber ich bin mit dieser version mit jdk 10 netbeans dev ed
  • Sie haben dieses Thema wieder nach vorne. Es ist Netbeans, dass nicht finden können, Java, nicht die andere Weise herum. Sie müssen passen Sie den Pfad zum Java-binary irgendwo in der Netbeans-Konfiguration-Dateien. Das gleiche gilt für Eclipse.
  • Setzen JDK-Pfad in Netbeasn wie vorgeschlagen von @EJP siehe diese StackOverflow Beitrag

InformationsquelleAutor oneslide | 2018-04-15



One Reply
  1. 0

    Ich bin neu in netbeans,damit ich resort zur Konfiguration in eclipse.ini,ich versuche, fügen Sie “–ALL“wie Skript,das ich nicht trotzdem arbeiten!Danke für meine Geduld,ich feststellen, dass einige jdk1.8required
    Eigenschaft,ich bin völlig Eile zu meinem Termin,so dass ich vermeiden Sie dieses problem,und habe 1.8,aber vielen Dank, wenn Sie empfehlen, eclipse-IDE, lastest version, die gut funktionieren kann mit JDK 10 ohne jede änderung in der ini-Datei!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.