Habe ich bereits installiert, pynotify, noch immer Fehler no module named pynotify

Habe ich bereits installiert mit pynotify :

pip install py-notify

Wenn ich re-run zeigt es :

Anforderung bereits erfüllt ist (verwenden Sie “ –upgrade, um ein upgrade).

Ich auch versucht :

pip install --upgrade py-notify 

aber es zeigt :

Anforderung bereits up-to-date.

Unten ist meine einfachen code, um den desktop anzuzeigen Benachrichtigung mit pynotify.

import pynotify    
pynotify.init("Basic")

n = pynotify.Notification("Title", "Some sample content")
n.show()

Was soll ich jetzt tun, um Sie unter code korrekt?

  • Sie nicht durch Zufall haben zwei Instanzen von Python installiert? Zum Beispiel Python ist im Anaconda-Verteilung.
  • Nein. Ich habe nur Python 2.7.9 in meinem system installiert. Ich bin mit ubuntu 15.04.
  • was passiert, wenn zwei Instanzen von python installiert ist ,bcz ich bin auch vor dem gleichen Problem und ich habe Anaconda distribution auch .(ich bin mit macOs)
InformationsquelleAutor Parth Shihora | 2016-05-07



3 Replies
  1. 2

    Wenn Sie brauchen, um zu senden GTK-Luftballons – hast du nicht installiert richtige Bibliothek.

    Wenn Sie verwenden möchten „Observer pattern Programmierung“ (Rückruf-management) – Sie verwenden die falsche syntax.

    Gibt es zwei ähnliche Pakete:

    • pynotify – wrapper für libnotify, die zeigt, dass desktop-Ballons zu Benachrichtigen Benutzer über einige Ereignisse. Benötigt PyGTK (http://www.pygtk.org/) zu arbeiten. Kann nicht installiert werden von pip. In der Regel installiert mit einigen OS-Paket (so etwas wie python-pynotify). Verwendung: import pygtk;pygtk.require('2.0');import pynotify.
    • notify2 (https://pypi.python.org/pypi/notify2) – alternative wrapper für libnotify. Installiert werden kann von pip. Verwendung: import notify2

    Gibt es auch zwei voneinander unabhängige Pakete mit ähnlichen Namen:

    • pyinotify (https://pypi.python.org/pypi/pyinotify) – wrapper-lib fürichBenachrichtigen, dass ermöglicht die überwachung des Dateisystems ändert. Verwendung: import pyinotify.
    • py-notify (https://pypi.python.org/pypi/py-notify) – python-only-Bibliothek, die Haken (callback) – Speicher, aufrufen und filtern mit keine verbindungen zur Außenwelt (third-party-Bibliotheken oder-standards). Verwendung: import notify.
  2. 0

    Gibt es einen Namen in Konflikt mit pynotify.

    Hatte ich installiert pynotify von PIP mit:

    sudo pip install pynotify

    Da, dass die falsche Wahl war, habe ich es entfernt mit:


    sudo pip uninstall pynotify

    Und installiert dann die erwarteten mit pynotify:

    sudo apt install python-notify

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.