AttributeError: ‚module‘ Objekt hat kein Attribut ‚version‘ Canopy

Hallo ich werde Vorwort dies mit der könnte ich auch einfach wirklich dumm, also nicht zu übersehen, dass, aber plötzlich beim öffnen der Kabinenhaube heute war ich nicht in der Lage zu laufen, eine meiner typischen Skripts mit der Fehlermeldung AttributeError: ‚module‘ Objekt hat kein Attribut ‚version‘, wenn Sie versuchen zu laden pandas. Von dem, was ich sammeln können, es scheint, als holprig ist aufgerufen, durch pandas es scheitert. Ich überprüfte mein Arbeits-Verzeichnis nach Dateien mit den Namen numpy.py um zu sehen, ob ich idiotisch den Namen einer Datei numpy aber nicht zu finden, wie eine Datei. Ich habe auch versucht zu deinstallieren und installieren Sie beide numpy und pandas aus dem Paket-manager in den Baumkronen. Irgendwelche Vorschläge?

    %run "/Users/jim/Documents/ORAL-PAT-2.5-3.5plotly.py"
---------------------------------------------------------------------------
AttributeError                            Traceback (most recent call last)
/Users/jim/Documents/ORAL-PAT-2.5-3.5plotly.py in <module>()
      1 #import the modules you need
----> 2 import pandas as pd
      3 import numpy as np
      4 import plotly.plotly as py
      5 import plotly.tools as tls

/Users/jim/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/pandas/__init__.py in <module>()
     20 
     21 # numpy compat
---> 22 from pandas.compat.numpy_compat import *
     23 
     24 try:

/Users/jim/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/pandas/compat/numpy_compat.py in <module>()
     13 
     14 # numpy versioning
---> 15 _np_version = np.version.short_version
     16 _np_version_under1p8 = LooseVersion(_np_version) < '1.8'
     17 _np_version_under1p9 = LooseVersion(_np_version) < '1.9'

AttributeError: 'module' object has no attribute 'version' 
  • Hatten Sie getan, ein manuelles update der pandas, die außerhalb der Paket-manager?
InformationsquelleAutor Dumb_Dumb | 2016-09-02



One Reply
  1. 0

    Hatte gerade das gleiche problem nach der Herabstufung Pandas und Modernisierung wieder zu lösen ein anderes Problem. Dies ist nur ein hack, aber Sie könnten versuchen, diese:

    Öffnen ...pandas/compat/numpy_compat.py und ersetzen np.version.short_version mit np._np_version

    Hoffe, das hilft!

    • Hi, diese Art gearbeitet, aber es hat mich nur gefragt, um pandas Hashable in C. Dies gab mir die Idee zu gehen, in die das unerwartete Ordner zu löschen pandas manuell und dann neu installieren mit dem Paket-manager. Diese resoled das problem. Vielen Dank für die Hilfe!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.